Echo 1 Owners Group

This is a forum for all people who love airsoft, and Echo 1
 
HomeFAQSearchRegisterMemberlistUsergroupsLog in

Share | 
 

 My Echo1... no pictures yet. Questions though...

View previous topic View next topic Go down 
AuthorMessage
Lenbo
Private Second Class


Number of posts : 1
Registration date : 2007-10-19

PostSubject: My Echo1... no pictures yet. Questions though...   Fri Oct 19, 2007 7:34 pm

Heya everyone. I'm quite happy that there is an Echo1 forum...

I have the DMR myself, and the only real "mod" I've done to it is the Systema BS 6.04 inner barrel. I just ordered a few more parts, and they're en route.

I did have a question though... Lately I've been putting (or more accurately, trying to put) the black .20g's by Airsoft Elite and they often misfeed. I didn't seem to have a problem putting .20g Excels through it. Obviously there are quality differences between each brand of bb's, but I was curious if anyone had any ideas beyond the possibility of the AE bb's just not being up to par.

When the rest of my parts get here, I'll be putting .43g Straights through it, but in the interim... yanno. Very Happy
Back to top Go down
View user profile http://www.abileneairsoft.com
crimsonfalcon07
Admin
Admin
avatar

Number of posts : 86
Registration date : 2007-02-24

PostSubject: Re: My Echo1... no pictures yet. Questions though...   Mon Nov 26, 2007 12:51 pm

That's interesting, because AE bb's are the best you can buy. I did hear about a batch of AE's having issues though. I'm surprised that the Excels work; I've had way more issues with Excel than with AE.

Some things to try--be sure that the hopup bucking is installed correctly on the barrel. Wash your bb's before use (you should do this anyways). Try a different magazine. That's still surprising to me though. Good luck!
Back to top Go down
View user profile
mrobben
Private First Class
Private First Class


Number of posts : 40
Registration date : 2007-03-24

PostSubject: Re: My Echo1... no pictures yet. Questions though...   Sun Apr 06, 2008 7:29 pm

a bit late.. but I swear by KSC
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: My Echo1... no pictures yet. Questions though...   

Back to top Go down
 
My Echo1... no pictures yet. Questions though...
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Off Road Pictures [PICTURES ONLY, NO TEXT POSTS]
» Pictures of tire, wheel, and suspension thread
» Pictures of Stereo Installs
» how to easly blur the background of your pictures (photobucket)
» New here with some questions

Permissions in this forum:You cannot reply to topics in this forum
Echo 1 Owners Group :: Echo 1 USA Discussion :: Echo 1 Mods-
Jump to: